Переход к официальным ресурсам:      Codeigniter4 / Документация / Github / Форум / CodeIgniter3
Привет! В настоящий момент я временно прекратил перевод документации по причине того, что она она содержит целый ряд неточностей, а также еще дорабатывается со стороны разработчиков. Если ты заинтересован в изучении фреймворка CodeIgniter 4, то приглашаю тебя на свой канал на YouTube (Перейти на канал), где я более подробно выкладываю занятия по данному фреймворку.


Необходимые требования к серверу

Для полноценной работы CodeIgniter 4 твой сервер должен соответствовать следующим системным требованиям:

  • Установленная версия языка PHP не ниже 7.2;
  • Установленная ICU библиотека для поддержки расширения *intl*;
  • На сервере должны быть включены следующие расширения: php-json, php-mbstring, php-mysqlnd, php-xml;
  • Если ты планируешь использовать в своих проектах сURL запросы, тогда необходима установленная библиотека libcurl;

Для большинства проектов требуется использование баз данных. В настоящий момент CodeIgniter 4 поддерживает работу со следующими типами баз:

  • MySQL (5.1+) через драйвер MySQLi;
  • PostgreSQL через драйвер Postgre;
  • SQLite3 через драйвер SQLite3.

По состоянию на конец 2019 года, CodeIgniter 4 находится еще в разработке и поддержка других типов баз данных еще не перенесена в новую версию. Однако, уже совсем скоро, будет доступна поддержка следующих типов:

  • MySQL (5.1+) через драйвер pdo;
  • Oracle через драйверы oci8 и pdo;
  • PostgreSQL через драйвер pdo;
  • MS SQL через драйверы: mssql, sqlsrv (только для версии 2005 и выше) и pdo;
  • SQLite через драйверы sqlite (версии 2) и pdo;
  • CUBRID через драйверы cubrid и pdo;
  • Interbase/Firebird через драйверы ibase и pdo;
  • ODBC через драйверы: odbc и pdo (важно помнить, что ODBC на самом является уровнем абстракций).

Если параметры твоего сервера отвечают всем необходимым требованиям, тогда смело переходи к установке фреймворка в ручном режиме или установке с помощью Composer.


Комментарии к разделу:

Кто-то уже оставил свои комментарии. Оставить свой!

все-таки, наверное, драйвер PostGre для базы PostGre :-)
» Написал: mokinys (17-12-2019 в 17:23) Ответить
Спасибо большое, поправил!
» Ответил: code4 (17-12-2019 в 19:25) Ответить

Добавить комментарий к статье:


Ваше имя:
Ваша почта:

  Закрыть